Edmentum System Issue

Incident Report for Quaker Digital Academy

Resolved

This incident has been resolved.
Posted Sep 25, 2025 - 09:48 EDT

Update

We are continuing to investigate this issue.
Posted Sep 25, 2025 - 09:48 EDT

Update

Edmentum has created an incident report. Additional updates can be found here: https://status.edmentum.com/incidents/k3xq929bqx25
Posted Sep 25, 2025 - 09:40 EDT

Investigating

We are investigating an issue with the Edmentum Courseware platform that is preventing students from accessing their content and receiving error messages.
Posted Sep 25, 2025 - 09:24 EDT
This incident affected: Student Systems.